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Before you begin 

Demonstration mode 

If you have downloaded MEGS_Log and don’t have a MEGS_Log licence dongle then MEGS_Log will 
only operate in demonstration mode.  You will not be able to save any of the changes that you make 
to borehole files that you open, and you will not be able to print sample tags or graphics.  All other 
tools and functions of the program should be available so that you can thoroughly test the software 
on your site’s data. 

More help is available 

The instructions in this guide are intended to get you quickly up and working with the example 
boreholes that are provided with the MEGS_Log install. 

In addition to this guide, MEGS_Log comes with extensive on-line help – available under the Help 
menu item in the main MEGS_Log window.  You can also press the F1 key at any time within 
MEGS_Log to get context sensitive help. 
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If you are a Prolog version 2.1 or version 3 user 

 Start up MEGS_Log by double-clicking on the desktop icon. 

 Click on the right borehole display (the name at the top will turn pink to indicate its selection). 

 Click the Open File icon ( ) or select File then Open from the menu. 

 Select the file called PLexample, ensure the Files of Type at the bottom of the browser 
window says Prolog files (*.*) and then click the Open button. 

 A dialog box opens prompting you to select a schema to use.  Pick the schema called 
PL3example and click OK.   

 If every unit in the borehole display is shown as a red diagonal cross, then go to the Tools menu 
and select Options.  Click on the Project tab, select BHPLexample for the hatch list. Click the OK 
button.    

 Click the Open Trace icon ( ) or click on the File menu and select Open Trace. 

 Select the ExampleDEN.LAS file and click the Open button. 

You are now ready to start correcting the example Prolog file.  See the section on Basic editing 
operations below. 

Defining custom schemas for Prolog files 

If you would like to open your own Prolog file, then you will need to define your own Prolog 
“schema”.  The best way to do this is to start MEGS_Log and, without opening any holes, go to Tools 
> Options on the menu, select the Settings tab and click on the Edit schemas button.  You will see 
a dialog box similar to the following: 

 

Figure 1: The Schema Editor dialog box 
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Click on the Add new button to display the New Schema dialog box.   

 

Figure 2: The New Schema dialog box 

Enter a name for your new schema, and then select an existing Prolog 2.1 or Prolog 3 schema (for 
example, the Prolog21 or Prolog3 schemas, respectively, provided with MEGS_Log) to use as a 
starting point for the new schema.  Click on OK to return to the Schema Editor dialog box. 

You can now use the Schema Editor to edit the name and type of fields in the schema to match your 
Prolog configuration, as it appears in the main Prolog window.  Note that there are some restrictions 
imposed on the schema by MEGS_Log and Prolog: 

 For compatibility reasons, schemas intended for use with Prolog 2.1 and Prolog 3 should end 
with two STRING fields that are additional to the fields shown in the Prolog display.  These 
additional fields mark the end of each record and are not available for logging data. 

 Schemas for use with Prolog 2.1 need a total of 25 fields (including the extra STRING fields at the 
end of the schema).  The number of fields for a schema intended to be used with Prolog 3 file 
can vary. 

 The first three fields in the schema must be the ROCKTYPE field, followed by the PERCENTAGE 
field, followed by the SEAM field (if you intend to use MEGS_Log to assign seams and/or plies to 
units). 

 The last three fields in the schema (before the extra STRING fields) must be the RECOVERED 
field, followed by the THICKNESS field, followed by the BOTTOM field. 

 

Figure 3: Example Prolog schema,showing the additional STRING fields at the end of the schema. 

The type of the remaining fields should be selected to match the layout of your data.  If you want to 
carry out correlation (assign seam and ply names to units) within MEGS_Log, then consider including 
a SEAM field or both a SEAM and a PLY field.  If you want to assign sample numbers to units then 
include a SAMPLE field.  Other fields should generally be given the  STRING type, though INTEGER or 
REAL fields may also be appropriate – see the MEGS_Log online help for more information.   

The field descriptions are only used within MEGS_Log to label the fields in the Unit Properties dialog 
box, or when exporting files from one schema to another. 

Once you have finished editing your schema you should be able to open your own Prolog file in the 
same way as the PL3example hole detailed above.   
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If you are a Prolog version 4 user 

MEGS_Log does not include an example file for Prolog 4.x.  Instead, you can use the example file that 
is installed when Prolog version 4 is installed – typically example1.prolog in the Prolog_4 folder in 
your My documents folder.  Note that this file may require recalculation within Prolog to ensure that 
depths and thicknesses are consistent before you can load it into MEGS_Log. 

 Start up MEGS_Log by double-clicking on the desktop icon. 

 Click on the right borehole display (the name at the top will turn pink to indicate its selection). 

 Click the Open File icon ( ) or select File then Open from the menu. 

 Set the Files of Type at the bottom of the browser window says Prolog version 4.x 
files (*.prolog), navigate to the folder that contains the example Prolog 4 file, select the file and 
then click the Open button. 

 A dialog box opens prompting you to select a schema and other settings to use when opening 
the file.  For the example provided with Prolog 4, select Deduce schema, set the Data log to 
RockType, and click OK.   

 If every unit in the borehole display is shown as a red diagonal cross, then go to the Tools menu 
and select Options.  Click on the Project tab, select BHPLexample for the hatch list. Click the OK 
button.    

 Click the Open Trace icon ( ) or click on the File menu and select Open Trace. 

 Select the ExampleDEN.LAS file and click the Open button. 

You are now ready to start correcting the file.  See the section on Basic editing operations below. 
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If you are a CSV file user 

 Start up MEGS_Log by double-clicking on the desktop icon. 

 Click on the right borehole display (the name at the top will turn pink to indicate its selection). 

 Click the Open File icon ( ) or select File > Open from the menu. 

 Select the file called Example.csv, ensure the Files of Type at the bottom of the browser window 
says CSV files (*.csv) and then click the Open button. 

 A dialog box opens prompting you to select a schema to use.  Pick the schema called 
CSVexample.  Check that the Quoting section has the radio button Use double quote (“) 
selected.  Heading rows should be 1 and the Interbedded unit record location should be 
picked as No unit level record.  Click the OK button and the hole will be opened.   

 

Figure 4: File settings for the CSV example 

 If every unit in the borehole display is shown as a red diagonal cross, then go to the Tools menu 
and select Options.  Click on the Project tab, select BHCSVexample for the hatch list.  Click the OK 
button.   

 Click the Open Trace icon ( ) or click on the File menu and select Open Trace. 

 Select the ExampleDEN.LAS file and click the Open button. 

You are now ready to start correcting the example CSV file.  See the section on Basic editing 
operations below for more information on how to edit boreholes. 

Defining custom schemas for CSV files 

If you would like to open your own CSV file, then you will need to define your own CSV “schema”.  
The best way to do this is to start MEGS_Log and, without opening any holes, go to Tools > Options 
on the menu, select the Settings tab and click on the Edit schemas button.  You will see a dialog box 
similar to the following: 
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Figure 5: The Schema Editor dialog box 

Click on the Add new button.  Enter a name for your new schema and click on OK to return to the 
Schema Editor dialog box. 

 

Figure 6: Creating a new schema 

You can now use the Schema Editor to edit the name and type of fields in the schema to match the 
columns in your CSV file.   

There are some fields that must be defined within the schema, these are ROCKTYPE and BOTTOM.  
Other fields that are significant for definition are PERCENTAGE, SEAM, SAMPLE, PLY, RECOVERED and 
THICKNESS.  All other fields are simply defined as strings and will not be altered within MEGS_Log 
(unless you delete a unit, or merge one unit over another).  The field names enclosed in quotation 
marks do not have to be exactly as written in the CSV file headings (you don’t even need headings in 
the CSV file), they are simply the field names that will be displayed for each parameter in the Unit 
properties box within MEGS_Log. 

Other CSV import settings 

If you have interbedded units logged, you may need to adjust the settings for Interbedded unit 
record location in the CSV options tab window of Tools-Options.  The following examples will give 
you an idea of what to select. 
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If your data looks like this: 

Holename, 
From, 

To, Interbed, Percent, lith 

BHExample, 17.93, 18.66, I, 50, CL 

BHExample, 17.93, 18.66, I, 50, CU 

      
You should select No unit level record. 

For this: 

DEPTH_FROM, DEPTH_TO, LITH, LITH_PERCENT 

62, 87, IB, 100 

62, 87, SL, 30 

62, 87, CL, 70 

    
You should select Before interbedded elements. 

If the indicator record for the interbedded unit occurs after the records containing lithology 
percentages, you would select After interbedded elements. 

The Unit rock type for interbedded units field on the Project tab of the Tools > Options 
menu would be blank for the first example above, and should be IB for the second example.  At 
present, MEGS_Log does not support the Minex-style of interbedded records where the second 
(third, …) records have the same “from” value as “to”.  This is because the graphics cannot draw a 
pattern for a zero thickness element. 
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Basic editing operations 

The following instructions assume that MEGS_Log is in the “Normal” editing mode (the default mode 
when the application starts and that no boreholes, units or traces are currently selected.  The current 
editing mode is displayed in approximately the middle of the status bar at the bottom of the 
MEGS_Log main window, while selected objects are outlined in a different colour. 

You can ensure that MEGS_Log is in Normal Mode and cancel the current selection by repeatedly 
pressing the Escape key until Normal is displayed in the status bar and none of the boreholes, traces 
or units are highlighted.  

Adjusting unit depths 

1. Move the mouse cursor over the boundary that you want to move, so the cursor changes to a 
double-headed arrow.  

 

2. Hold the left button down and drag the boundary to the desired location. 

Editing unit rock type/lithology 

 Double left-click within the area of the unit that you want to change. 

or 

1. Select the unit that you want to change by left clicking in its area 

2. Press the Enter key 

or 

 Right click within the area of the unit that you want to change, and select Set Rocktype. 

All three of the above options will result in the Set Rock Type dialog box being shown. 

 

Figure 7: The Set Rock Type dialog box 
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Editing unit seams and plies 

1. Right click on the area of the unit that you want to change and select Correlate. 

2. If this is the first time you have used the correlation function within MEGS_Log you may be 
prompted to choose a correlation site.  For the Prolog example discussed above choose 
PL3exampleSITE, while for the CSV example choose CSVexampleSITE. 

3. Use the Correlate dialog box to specify the new seam and/or ply. 

 

Figure 8: The Correlate dialog box 

Note that MEGS_Log either displays seam and ply information or sample number information in the 
area immediately to the right of each borehole.  You can change between seam and ply information 
or sample number information by using the View menu. 

Editing unit sample numbers 

1. Right click on the area of the unit that you want to change and select Sample Number. 

2. Use the Sample Number dialog box to specify the new number. 

 

Figure 9: The Sample Number dialog box 
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Settings common to both Prolog and CSV files 

The current hatch list 

If your hole opens up and shows nothing but red crosses through every unit, then you need to 
change the hatch list.  Hatch lists within MEGS_Log associate a particular rock type or lithology with a 
graphical pattern.  The active hatch list also determines the list of rock types available to be assigned 
to a unit. 

To change the active hatch list, select the Tools > Options menu item to display the MEGS_Log 
Options dialog box and then select the Project tab.  You will see a pick-box for an item called Hatch 
list.  For the Prolog example discussed above choose BHPL3example, while for the CSV example 
choose BHCSVexample from this list. 

 

Figure 10: Setting the hatch list 

If you want to change the names of the rock types/lithologies available in a particular hatch list, or if 
you want to change the pattern that is drawn for each rock type, or if you want to create a new hatch 
list, then use the Hatch List Editor.  To display the Hatch List Editor, within the Options dialog box 
select the Settings tab and click the Edit hatch lists button. 
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Figure 11: The Hatch List Editor dialog box 

Three types of hatch patterns are available for use within MEGS_Log to draw the graphics associated 
with each rock type – “bitmaps” (fixed resolution images), “vectors” (scalable images) and “inbuilts”.  
MEGS_Log comes installed with both bitmap and vectors patterns that are suitable for most 
applications, however if necessary you can edit these patterns or create new patterns.  The list of 
inbuilt patterns is fixed. 

For more information on editing hatch lists, vectors and bitmaps consult the on-line MEGS_Log help. 

Setting the list of seams and plies 

When correlating, the list of seams and plies available from within MEGS_Log is determined by the 
“Site” setting.  To change the current site, select the Tools > Options menu item to display the 
MEGS_Log Options dialog box and then select the Project tab.  You will see a pick-box for an item 
called Site.  For the Prolog example discussed above choose PL3exampleSITE, while for the CSV 
example choose CSVexampleSITE from the associated list. 
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Figure 12: Setting the site to use for correlation 

To create new sites, or to edit the list of seams and plies available for an existing site, use the Seams 
and Plies editor.  To display the Seams and Plies editor go to Tools > Options on the menu, select 
the Settings tab and click on the Edit seams and plies button.   

 

Figure 13: The Seams and Plies Editor dialog box 

Where are the settings saved? 

When you edit aspects of MEGS_Log configuration (schemas, hatch lists, seams and plies, etc) your 
changes will be saved to the configuration file (MegslogConfig.txt) in the user specific application 
data directory.  On Windows XP this directory is typically C:\Documents and 
settings\username\Application Data\MEGMS\MEGS_Log 3.0, on Windows Vista it is typically 
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C:\Users\username\AppData\Roaming\MEGMS\MEGS_Log 3.0.  Saving the config file in this folder 
means that installations of later versions of the software will not overwrite your configurations for 
file schemas, hatches, site seam codes etc.  After carefully testing your schema you can copy your 
user specific configuration file over the default configuration file supplied with MEGS_Log (installed 
in the Program Files folder for MEGS_Log).  All users on the computer will then be able to use that 
schema. 

Note that installation of a new version of MEGS_Log may overwrite the configuration file in the 
Program Files folder for MEGS_Log.  If you make changes to the file in this location it is strongly 
recommended that you save a copy elsewhere as a backup. 
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List of shortcut keys 
Keys: Function: 

i Zoom in 

o Zoom out 

[Ctrl] – n Create a new hole 

[Ctrl] – o Open a hole 

[Ctrl] – s Save the hole(s) 

[Ctrl] – p Print 

[Ctrl] – z Undo 

[Ctrl] – f Fine scroll on/off 

Insert Toggles between Overwrite & Insert modes 

F1 Help 

F2 Create boundary 

F3 Pick & Drag 

F4 Set Rock 

F5 Merge 

F6 Insert 

F7 Set Base Depth 

F8 Correlate / Sample Number 

F9 Delete 

Esc Normal mode 

Use the right-click mouse menu for: 

 Unit Properties 

 Merge 

 Correlate 

 Sample Number 

 Set Rocktype 

 Delete 

 Set Scale 

 Set Display Top Depth 

When in NORMAL MODE: 

 Left-click to select a unit.  Click and drag to select multiple units. 
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 Use the double-headed arrow to move a unit boundary. 

 [Alt] – click Creates a boundary 

 [Alt] – click & drag Inserts a unit 

 The Shift key switches the mode between Insert and Overwrite, so if (with Overwrite mode set) 
you select: 

o [Shift]+[Alt] – click & drag: MEGS_Log will insert a unit as if it were 
in Insert mode, or 

o [Shift] + drag: the double-headed arrow will move the boundary 
(and all others below it) as if it were in Insert mode. 
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